Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Computer ControlsComputer Controls
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Wzmocnienie sygnału sensora ciśnienia

17 Mar 2008 15:51 2618 11
  • Level 10  
    Witam wszystkich,

    Chciałbym wzmocnić sygnał sensora ciśnienia, który bazuje na mostku Wheatstone'a. Przeczytałem, że niby najlepszy jest do tego wzmacniacz instrumentalny i taki użyłem a dokładnie AD8221ARMZ. Zmontowałem układ ale po podłączeniu sensor ciśnienia nie otrzymuję żadnego wzmocnienia. Bazowałem na dokumentacji ze wzmacniacza. Poniżej załączam schemat. Proszę o pomoc.


    Wzmocnienie sygnału sensora ciśnienia
    Czy Twoje urządzenia IoT są bezpieczne? [Webinar 22.06.2021, g.9.00]. Zarejestruj się za darmo
  • Computer ControlsComputer Controls
  • Level 1  
  • Computer ControlsComputer Controls
  • Level 10  
    Dzięki za odpowiedź. Nie rozumiem co to znaczy niekompletny? Zamotany ok :) Nie jestem nawet początkującym elektronikiem ale mój konwerter AC/DC może odczytać tylko napięcie +/- 10V. Przeszukałem parę stron www i znalazłem ten wzmacniacz. Zrobiłem najlepiej jak umiałem :) Miernik nie pokazuję nic, czasami tylko jakieś skoki, konwerter to samo. Wrzuciłem drugi wzmacniacz i to samo sie dzieję, wiec pomyślałem, że coś musi być nie tak ale nie potrafię znaleźć przyczynę stąd ten post. Podpinam schemat płytki.
  • Level 39  
    Masz niespolaryzowane wejścia - poczytaj na stronie 18 datasheet'a, "Input bias current return path".
  • Level 10  
    Z tego co rozumiem musze uziemić sensor? Ja chciałem zrobić cos podobnego jak na stronie 16 w moim data sheet (PRECISION STRAIN GAGE). Coś pominąłem?
  • Level 39  
    U mnie to jest 19 strona ;) Wrzuć schemat mostka, łącznie z jego zasilaniem.
  • Level 10  
    Postaram sie może to w skrócie streścić. Używam sensora 26PC poniżej link jest tam opis:

    http://www.sensortechnics.com/index.php?fid=3...0&aps=0&blub=9fc5d3aa5e62aaccb9aa912cf0aef960

    Zasilanie tego sensora to napięcie max 16V ja podaję 10V. Wyjście z sensora to napięcie pomiędzy 0-100mV. Poniżej załączam jak to miej więcej podłączyłem. Mam zasilacz 24 VDC poprzez L78S10V zmieniam napięcie z 14 na około 10V dla sensora, z tego samego zasilacza zasilam wzmacniacz ale przedtem zmieniam napięcie na 10V poprzez MAX6043. Podłączyłem sygnał referencyjny 5V ponieważ ciśnienie mierzone może być ujemne. Dlatego np. dla ciśnienia -2 bar będzie to 0 V a dla 2 bar 10V. Tak ja to rozumiem, że to może działać. Proszę mnie poprawić jak się mylę. To wszystko podpinam pod wzmacniacz AD8221 i dla mnie na wyjściu powinno być coś około max 10V ale nie mam nic :/ Rezystor 1K albo 499 ohm co powinno dać wzmocnienie 100 albo 50 razy. Mam nadzieję, że teraz mnie lepiej zrozumiecie :)
  • Level 39  
    Nie obraź się, ale zarówno schemat jak i płytki drukowane są nieźle zakręcone ;) Nie wiem, po co użyłeś MAX6043, bo to formalnie żródło napięcia odniesienia, ale powinno działać. Jedyne co mi się rzuca w oczy to podłączenie płytki sensora - upewnij się, że zasilanie idzie na nóżki 1-3, a sygnał jest brany z 2-4. Nie widziałem okablowania płytek, ale sądząc po płytce sensora to wcale tak nie musi być ;)
    Jeśli wszystko wydaje się OK, to miernik w dłoń i po pierwsze posprawdzaj napiecia zasilające na układach...
  • Level 10  
    Dzięki, posprawdzam jeszcze raz. Liczyłem się z falą krytyki więc nie ma sprawy :) Mój pierwszy układ. Dam znać czy poszło.
  • Level 10  
    Cos dalej nie działa. Albo coś z płytką albo ze wzmacniaczem. Znalazłem inny A620 z opisanym schematem. Może spróbuję bo z tym coś nie idzie i nie wiem dlaczego:/
  • Level 39  
    Nie poddawaj się - układ jest na tyle prosty, że musi działać ;) Jakie są napięcia na wyjściach mostka - względem masy?
  • Level 10  
    Dzięki za wsparcie. Mam napięcia po max-ie 10V idzie do wzmacniacza, z sensora mam również napięcie i to wszystko idzie na wzmacniacz ale za wzmacniaczem cisza:/ Nie wiem czy go spaliłem lutując czy jak. Zmieniłem na inny ale to samo:/ Postaram się zrobić jeszcze jedną płytkę i będę ostrożny.
pcbway logo