Elektroda.pl
Elektroda.pl
X
Metal Work Pneumatic
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Bosch SMS53M08EU - po wymianie programatora zmywarka nie suszy

Hubercik_10 19 Mar 2018 19:56 699 8
  • #1 19 Mar 2018 19:56
    Hubercik_10
    Poziom 8  

    Witam!
    Opiszę problem ze zmywarką od początku, ponieważ ciąg przyczynowo skutkowy jest tutaj istotny.

    Jakiś czas temu w zmywarce Bosch SMS53M08EU padła mi pompa myjąca - dokładnie łożyska ślizgowe wałka wirnika. Ponieważ Bosch życzy sobie jakieś niebotyczne pieniądze za tę kupę plastiku, a że w pracy mam tokarza poprosiłem go o wytoczenie tych łożysk ślizgowych z brązu. Łożyska ładnie pasowały, wirnik obracał się bardzo lekko i pomimo pewnych trudności z rozmontowaniem teoretycznie nierozbieralnej pompy udało mi się ją rozłożyć i ponownie złożyć, działa.

    Niestety przy montażu pompy przez moją nieuwagę z węża spustowego wylała się woda i jak podejrzewam zalała mi elektronikę. Ponieważ nie sprawdziłem tego dokładnie i tylko pobieżnie wysuszyłem urządzenie, skręciłem wszystko, podłączyłem, uruchomiłem program i czekam. Minęło około 5 minut programu, po czym słychać było przełączenie się przekaźnika, następnie seria iskier z programatora, wywalone korki w domu i urządzenie zgasło. Po wyjęciu programatora na pierwszy rzut oka widać spalony duży rezystor, nie wiem czy coś jeszcze - na elektronice za bardzo się nie znam, jestem mechanikiem. Założyłem, że cała elektronika mogła ulec uszkodzeniu więc rozpocząłem poszukiwania zastępczej. Udało mi się znaleźć na pewnym popularnym portalu aukcyjnym programator o tym samym oznaczeniu producenta z tego samego roku w okazyjnej cenie, więc ucieszyłem się i zamówiłem. Jak się później okazało, co było dla mnie nieprawdopodobne, programator był ze zmywarki boscha o takim samym układzie przewodów, z taką samą elektroniką ale z modelu o innym oznaczeniu z (prawdopodobnie) inną konfiguracją programów myjących.

    Po podłączeniu nowego programatora urządzenie wstało, panel przedni ożył, jednak przyciski powodowały kompletnie inne działania niż pierwotnie (np. mycie krótkie ustawiało długi program mycia, 1/2 załadunku powodowała wydłużenie mycia, przyciski od opóźnienia czasowego powodowały zmianę programu). Na czuja ustawiłem jakiś program i uruchomiłem urządzenie. Zmywarka ruszyła, cały program dobiegł do końca, mycie zasadnicze działa, woda gorąca. Niby wszystko ok, ale tu pojawia się problem identyczny wręcz jak w tym wątku: https://www.elektroda.pl/rtvforum/topic3414255.html
    Zmywarka nie suszy naczyń, po zakończeniu programu stoi woda, mniej więcej przez ostatnie pół godziny programu słychać buczenie pompy myjącej, jednak brak wody. Jak doleję w tym czasie garnek wody to naczynia są suche i wszystko przebiega ok. Mógłbym przyjąć, że rozwiązanie problemu zastosowane w przytoczonym wątku może też być zastosowane w moim przypadku tylko, że u mnie nie ma elektrozaworu. Fabrycznie w jego miejsce jest włożona czerwona zaślepka.

    Moja interpretacja tej sytuacji jest taka, że kupiłem moduł sterujący od zmywarki niemalże mechanicznie identycznej, z wyjątkiem elektrozaworu. Cykl programu jest dostosowany do współpracy z elektrozaworem co skutkuje nieprawidłowym napełnianiem się płaszcza. W efekcie jeśli nie doleję wody w trakcie mycia to naczynia wychodzą nie domyte i mokre. Czy ktoś z Was może ma pomysł jak rozwiązać ten problem? Nowy programator dedykowany do mojego modelu to około 700 zł. Zmywarka ma 9 lat i inwestowanie takich pieniędzy w tak stare urządzenie mija się z celem. Mam taki pomysł, że może jakbym kupił sam elektrozawór i go wstawił w miejsce tej zaślepki to urządzenie byłoby w stanie kontrolować wtedy moment opróżniania i napełniania płaszcza. Co o tym sądzicie?

    Miałem też pomysł, że może ten moduł sterujący można przeprogramować (w starych zmywarkach Boscha kojarzę, że była taka możliwość) ale przewertowałem cały internet i nic na ten temat nie znalazłem - rozumiem, że te moduły są konfigurowane fabrycznie i już nic z nimi nie można zrobić?

    Z góry wielkie dzięki za pomoc!

    0 8
  • Metal Work Pneumatic
  • Pomocny post
    #2 19 Mar 2018 21:33
    hobbysta92
    Specjalista AGD

    Moduły sterowania mimo identycznego wyglądu różnią się programem wewnątrz pamięci - stąd rozbieżność w programach. Z moich informacji wynika że modułów nie programuje Bosch tylko wykonawca modułów dla Boscha. Pozostaje kwestia zakupu programatora dedykowanego do omawianego modelu zmywarki lub próba dołożenia wspomnianego elektrozaworu. Zapewne w instalacji Twojej zmywarki nie występuje para przewodów do podłączenia dodatkowego elektrozaworu, załączam zdjęcie miejsca w które należy go wpiąć.

    https://north.pl/karta/elektrozawor-do-zmywarki-bosch--00611316-,ITX-MM-ZL2Q-7VE.html

    Bosch SMS53M08EU - po wymianie programatora zmywarka nie suszy

    0
  • #3 19 Mar 2018 22:09
    misiek1111
    Poziom 23  

    Może zamienić pamięć z oryginalnego modułu do nowego.

    0
  • Metal Work Pneumatic
  • #5 19 Mar 2018 23:20
    kris8888
    Poziom 29  

    misiek1111 napisał:
    Może zamienić pamięć z oryginalnego modułu do nowego.
    Wsad pamięci (firmware) siedzi w wewnętrznej pamięci flash mikrokontrolera, nie ma tam oddzielnego, dedykowanego układu pamięci. Nie radze jednak podmieniać całego mikrokontrolera bo mogą też być drobne różnice układowe. Poza tym jest duże prawdopodobieństwo, że w oryginalnym module mikrokontroler już wyzionął ducha, a autor napisał też dodatkowo, że:
    Hubercik_10 napisał:

    na elektronice za bardzo się nie znam, jestem mechanikiem
    Lepiej więc niech szuka modułu dokładnie dedykowanego do tej zmywarki.

    2
  • #6 20 Mar 2018 09:24
    bubu64
    Poziom 21  

    Kupiłeś tylko dolny moduł?
    Wydaje mi się, że w tych zmywarkach powinno się zmienić dolny i górny moduł jeśli okablowanie pasuje:)

    0
  • #7 20 Mar 2018 09:37
    misiek1111
    Poziom 23  

    kris8888 napisał:
    Poza tym jest duże prawdopodobieństwo, że w oryginalnym module mikrokontroler już wyzionął ducha

    Może tak, a może nie :)
    Można zanieść do elektronika, który zamieni µP na płytce. Koszt 2 dychy?
    Skoro oznaczenie modułu jest takie samo, to różnic sprzętowych nie powinno być (tak mi się wydaje).

    0
  • #8 21 Mar 2018 12:10
    Hubercik_10
    Poziom 8  

    Dziękuję bardzo za odpowiedzi!
    Stary moduł posiadam postaram się wrzucić zdjęcia - założyłem po prostu, że układ mógł się spalić i raczej nie jest do odratowania. Sam lutowania tak małych elementów się nie podejmę, mógłbym to dać do elektronika jednak nie mam pewności, że ten stary układ jest sprawny.
    Tak, wymieniłem sam dolny moduł ze względu na brak wiedzy wtedy, że mogą występować tak diametralne różnice. Tak jak pokazał kolega ze zdjęciem u mnie ta jedna wtyczka jest węższa i brakuje tych dwóch przewodów do elektrozaworu.

    0
  • #9 13 Kwi 2018 19:39
    Hubercik_10
    Poziom 8  

    Witam po przerwie! Problem został rozwiązany.
    Tak jak któryś z kolegów wyżej radził, zakupiłem elektrozawór i sprawdziłem jak zmywarka będzie chodzić przy obecnej konfiguracji plus elektrozawór. Wymieniłem część wiązki na tą z brakującymi przewodami do elektrozaworu, podłączyłem wszystko i działa! Zmywarka elegancko myje, płucze i suszy! Dziękuję bardzo wszystkim za pomoc i może komuś temat się przyda przy podobnych problemach. Pozdrawiam!

    1