Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Opel astra 2 - nierowne wkrecanie na obroty podczas wysokiej temperatury.

drzasiek 27 Jun 2016 19:42 2181 37
  • #1
    drzasiek
    CNC specialists
    Witam. Mam problem w oplu z silnikiem 16xel gdy pracuje na benzynie. Silnik zagazowany 65 tys km temu. Na zimnyn silniku gdy temperatura na polu jest niska (powiedzmy ponizej 5 stopni) silnik pracuje w miare w porzadku jak na klekoteka. Natomiast gdy temperatura otoczenia jest wysoka np powyzej 20 stopni to silnik pracujw jak sieczkarnia, nierowno jakby na 3 gary a czwarty tylko troche. Jak dodam gazu na biegu jalowym to wchodzi na obroty skokowo. Jak silnik sie zagrzeje problem znacznie jest mniejszy, nie az tak uciazliwy i odczowalny. Na gazie pracuje w porzadku.
    Problem wystepuje juz od dawna, okresowe wymiany swiec, filtrow powietrza, paliwa nic nie zmianialy. Czyscilem przepustnice, podmienialem modul zaplonowy z powodu innej usterki ale nie mialo to wplywu ba opisywany problem.
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • Helpful post
    #2
    decybel91
    Level 42  
    Problemem jest zmieniona mapa wtrysku benzyny przez sterownik ECU.
    Aby się upewnić należy zakręcić butlę LPG, zresetować ECU silnik (odłączyć klemę na 12h) i pojeździć na SAMEJ benzynie. Jeśli problem ustanie to należy walczyć z LPG.
  • Helpful post
    #4
    zdzichra
    Level 30  
    Jeżeli jesteś pewny że zawory LPG trzymają należycie to nie musisz zakręcać butli.Zakręcenie zaworu na butli daje 100% pewność że gaz jest odcięty.
  • #5
    drzasiek
    CNC specialists
    W tym silniku (X16XEL) najwyraźniej nie resetuje się ecu poprzez zdjęcie klem.
    Po zabiegu nie ma żadnej różnicy.
    Jest jakiś inny domowy sposób czy koniecznie serwis który skroi mnie na niezłą sumkę za samo podłączenie?

    Czy uszkodzenie któregoś z czujników temperatury może powodować taki efekt?

    Mam OPEL TECH2 USB (tą tanią chińszczyznę na USB) która działa mi z AB-COM'EM w tym samochodzie. Może tam coś da się odczytać?
    Mam też ELM327 USB v1.5a ale z oplem nie udało mi się połączyć żadnym programem, natomiast działa bez problemu z chevroletem captiva.
  • Helpful post
    #7
    helmud7543
    Level 43  
    Jeśli nie masz możliwości skasować adaptacji, to po prostu pojeździj trochę na samej benzynie i zobacz czy sytuacja będzie się zmieniać. Jeśli to kwestia adaptacji to z czasem powinno się poprawić.
  • #8
    drzasiek
    CNC specialists
    Robiłem już takie eksperymenty.
    Tzn nie wiem ile to jest trochę, aby była szansa na poprawę. Pojechałem na benzynie 2 dni do pracy i spowrotem czyli zrobiłem 4 x 40 km. Nie pomogło.
  • Helpful post
    #9
    helmud7543
    Level 43  
    Jeśli nie ma różnicy, to raczej nie problem adaptacji. Tak czy siak, do rozwiązania na forum potrzebny jest podgląd parametrów pracy - czyli konieczność podłączenia komputera.
    Organoleptycznie zostaje jeszcze możliwość sprawdzenia czy nie zalewa - zobacz jaki jest zapach spalin. Ma być intensywny na zimny i szybko zanikać w miarę rozgrzewania. Zobacz, czy przy rozruchu nie puszcza niebieskiego dymka - jeśli tak - sprawdź zapach, pewnie będzie pachnieć nawet niespaloną benzyną.
    Opis wskazuje na zalewanie (niskie temperatury wręcz wymagają znacznie bogatszej mieszanki, ale przy upałach taki rozruch to już problem).
  • #10
    drzasiek
    CNC specialists
    Powiedz co podglądnąć, to wrzucę screeny albo filmik. AB-COM naprawdę sporo tych parametrów wyrzuca. Większość z nich rozumiem, jednak nie do końca wiem jak z nich wyciągnąć rozwiązanie gdyż nie jestem autośpecem.
    Byłem w piątek po drodze w dość dużym serwisie samochodowym (największym w mojej okolicy) gdzie dziesiątki samochodów dziennie się naprawia.
    Podłączono komputer ze skrzyneczką bosha i gość z przeglądał wszystkie parametry przez pół godziny po czym stwierdził że na diagnozę dłuższą muszę się umówić na inny dzień i kazali zapłacić 50 zł. A więc 50 zł zapłaciłem za to że gość pooglądał sobie to co ja oglądam sobie kabelkiem za 27 zł. Żadnej diagnozy nie postawił, powiedział że parametry wyglądają OK, jednak ze względu na znaczną gramotność podczas tej diagnozy nie wzbudził mojego zaufania.

    Jeśli chodzi o zapach spalin to ewidentnie czuć niespaloną benzynę.

    Dodam, że czujnik temperatury płynu chłodzącego działa poprawnie w zarkesie w jakim obecnie mogę go zmierzyć (20-90 stopni)
  • Helpful post
    #11
    helmud7543
    Level 43  
    Wszystko co związane z pracą silnika (nie jestem mechanikiem i nie znam tego interface), a najlepiej nagrać filmik przy rozruchu i podczas rozgrzewania i nagrać tabele z: prędkości obrotowej, temperatury powietrza i płynu (tu może być więcej niż jeden czujnik), przepływu powietrza, ciśnienia paliwa, czasu otwarcia wtrysków, pracy sondy lambda, EGR jeśli masz i pracy czujnika położenia przepustnicy.

    Jeszcze co do adaptacji - być może trzeba by mu pozwolić kilka razy rozgrzewać się na biegu jałowym - są wysokie temperatury więc silnik szybko rozgrzewa się do temperatury roboczej, może zwyczajnie jednak nie zdążył porobić nowych korekcji.

    Jaki tam jest gaz, chodzi o sterownik, reduktor i wtryski? Jaki przebieg ma reduktor i wtryski oraz czy filtry gazu wymieniane regularnie?
  • Helpful post
    #12
    mkpl
    Level 37  
    Mam dokładnie taką samą usterkę... auto ma problem powyżej 18*C pali ledwo co, gaśnie od razu. Po przełączeniu na LPG idzie jak nówka, na benzynie też jest ok jak już się rozgrzeje ponad 80*C.

    @ drzasiek nie wiem jak u Ciebie ale u mnie wtryski ok, świece ok, cewka ok i wszystkie pozostałe czujniki.

    Czy u Ciebie też śmierdzi paliwem z wydechu? Ja podejrzewam regulator ciśnienia paliwa.

    Dla pozostałych. Jeździłem ponad 500km na benzynie i zero poprawy więc u kolegi drzasiek też mała szansa, że to pomoże.
  • #13
    drzasiek
    CNC specialists
    Reduktor TOMASETTO, sterownik STAG4, wtryskiwacze valtec.
    LPG mam odkąd używam samochód czyli 3 lata, przebieg na gazie 65000 km.
    Problem występuje od dawna więc nie wiem co może być przyczyną.
    Czuć dziwny zapach z wydechu jak z zalanego rometa.
    Wyczyściłem dziś wtryskiwacze do LPG myśląc, że może się nie domykają i robią jakąś szkodę ale bez różnicy.
    Na gwarancji czyli przez pierwsze 2 lata wymieniałem filtry regularnie. Po gwarancji już nie regularnie, powiedział bym nawet że przeholowałem 2 krotnie. Ale problem był jeszcze w czasach gdy filtry wymieniałem więc go z nim nie kojarzę.

    U mnie na benzynie odpala na dotyk, ale jak silnik zimny a na polu ciepło to pracuje bardzo nierówno, jakby na 3 gary mając ochotę zgasnąć.

    Dodano po 45 [minuty]:



    Dodano po 5 [minuty]:

    Czy zbyt wysoka temperatura powietrza w dolocie (odczyt za wysoki) może powodować takie objawy? Jak widać odczyt jest ponad 40 stopni a na polu było około 24. Ale z drugiej strony nie wiem, czy nie zagrzał się dolot w komorze silnika od samego silnika.
  • #14
    helmud7543
    Level 43  
    Być może zostaje jednak skasowanie adaptacji - u mnie tak było. Wprawdzie inne auto (BMW E46) ale zasada działania osprzętu silnika jest podobna chyba w każdym z elektronicznym wtryskiem pośrednim. U mnie sonda stała - po wymianie elementów instalacji LPG od reduktora w górę, elementów układu zapłonowego i dolotowego została już tylko "martwa" sonda (i jej skutki - rozjechane korekcje, zalewanie na benzynie, check engine i podobny bajzel jak u Was - miałem to robić za jakiś miesiąc). Po skasowaniu błędów i adaptacji (przy okazji, bo byłem z czymś innym), już na w pełni sprawnym osprzęcie silnika i odświeżonej instalacji LPG, sonda - nie wiem jak - ożyła. Narazie (700 km od skasowania) spalanie katalogowe, rozruch bez problemu, check widzę tylko przy rozruchu (wcześniej, bez kasowania adaptacji, za każdym razem wracał na stałe po maks 200 km), obroty stabilne w każdych warunkach i na dowolnie wybranym paliwie - więc może to jest klucz i trzeba jednak ręcznie te adaptacje wyzerować? Jeśli sonda stoi, to nie ma szans by sterownik sobie poprawił korekcje, a słyszałem też o innych przypadkach, że potrafi przestać działać przy bardzo rozjechanych korekcjach - do tego stopnia, że podmieniali sondę na drugą i żadna nie chciała działać. Aż skasowali korekcje do fabrycznych.

    Dodano po 18 [minuty]:

    drzasiek wrote:
    Czuć dziwny zapach z wydechu jak z zalanego rometa.

    Skrajnie wzbogacona mieszanka - zalewa.
    drzasiek wrote:
    Reduktor TOMASETTO, sterownik STAG4, wtryskiwacze valtec.
    LPG mam odkąd używam samochód czyli 3 lata, przebieg na gazie 65000 km.
    Problem występuje od dawna więc nie wiem co może być przyczyną.
    Wyczyściłem dziś wtryskiwacze do LPG myśląc, że może się nie domykają i robią jakąś szkodę ale bez różnicy.
    Na gwarancji czyli przez pierwsze 2 lata wymieniałem filtry regularnie. Po gwarancji już nie regularnie, powiedział bym nawet że przeholowałem 2 krotnie. Ale problem był jeszcze w czasach gdy filtry wymieniałem więc go z nim nie kojarzę.

    Filtry filtrami, ale zapchany reduktor + zapchane/zużyte/rozkalibrowane wtryski i ECU próbuje nadrobić korekcją. Jak to działa? W przypadku STAG, jak się dobrze orientuję (jeśli nie, niech ktoś mnie poprawi), pracuje on na bazie danych z ECU silnika, wprowadzając mnożnik dla czasów otwarcia wtrysków gazu w stosunku do benzynowych. A tymi zarządza ECU. Im większa będzie rozbieżność między działaniem wtrysków benzyny i gazu (a te od gazu się rozkalibrowują, zapychają i zużywają, w przeciwieństwie do benzynowych, które długo zachowują parametry, więc te rozbieżności z czasem się zwiększają) tym bardziej sterownik silnika będzie to korygował. Gdybyś jeździł tylko na jednym paliwie, to nie byłoby problemu, przynajmniej dopóki korekcje nie wyszłyby poza dopuszczalne dla ECU zakresy. Ale przy zużyciu instalacji LPG (reduktor/wtryski) wydatek skacze, ECU nadrabia, jakoś to działa a po przełączeniu Pb jest całkowity bajzel. Kontrola LPG to nie tylko filtry, ale też sprawdzenie parametrów pracy reduktora i wtrysków, zweryfikowanie i skorygowanie mnożników czasów wtrysków, a jak się nie da - wymiana zużytych elementów.

    drzasiek wrote:
    Czy zbyt wysoka temperatura powietrza w dolocie (odczyt za wysoki) może powodować takie objawy? Jak widać odczyt jest ponad 40 stopni a na polu było około 24. Ale z drugiej strony nie wiem, czy nie zagrzał się dolot w komorze silnika od samego silnika.

    Gdyby to miało związek to prędzej startowałby na zbyt ubogiej mieszance albo gdybyś miał przekłamanie np: na -10°C.
  • #15
    rozales
    Level 24  
    Mam taka samą astre.
    Tyle, że bez gazu. Przebieg prawie 190 k.
    Objawy bardzo podobne. Jak się troche nagrzeje to zaczyna szarpać i potrafi na luzie zasnąć. Za 2 kilometry objawy zazwyczaj ustają. Jak jadę z nagrzewnica otwartą i wentylatorem na maxa to nieraz dojadę do pracy bez awarii. Zmienione czujniki obrotów korby i wałka rozrządu. I nic.
    Czytałem gdzieś,że to ECU jest uszkodzone.
    Jakaś firma w Rumi się w tym specjalizuje.
  • #16
    helmud7543
    Level 43  
    Tak, ale przy STAG to ECU steruje silnikiem i na benzynie i na gazie, a sterownik gazu tylko przełącza wtryski na gaz lub na benzynę oraz modyfikuje czasy otwarcia wtrysków gazu wg. wprowadzonego przy kalibracji modyfikatora (czasy otwarcia wtrysków benzyny oryginalny z ECU, czas otwarcia wtrysków LPG oryginalny z ECU * mnożnik wprowadzony w STAG). Gdyby ECU było problemem to problem byłby też na gazie.

    Patrzyłem na dane podane przez autora - czasy wtrysków na biegu jałowym 4 ms, jak przygasał, to jeszcze zwiększył (zanim autor wcisnął pedał gazu, jest tam taki moment gdzieś pomiędzy 30 a 40 sekundą filmu), czym pewnie zdusiłby go całkiem.

    Możliwe, że sonda stoi na ubogo jak u mnie i w paru innych znanych mi przypadkach (ale wtedy chyba miałby check engine na stałe zaświecony) albo, z racji upałów za szybko się grzeje i nie zdążył zapamiętać korekcji dla biegu jałowego przy niskiej temperaturze silnika.
  • Helpful post
    #18
    jack63
    Level 43  
    Panowie. O ile pamoętam x16xl ma przepływomierz. Nie bijcie jak się mylę. Mam nowszy silnik ijuż nie pamiętam opisow Waszego

    Sprawdźcie jego wskazania interfejsem
    Podobnie należy uczynić z ew. EGR. Znów nie bijcie jak go nie macie.
    Na Autokaciku jest fajna grupa Astry. Poszukajcie.
    W kwestii lepszego "kabla" diagnostycznego moge pomóc komuś z okolic Krakowa.
  • #19
    helmud7543
    Level 43  
    Oraz bardzo dokładnie wszystkie wężyki podciśnienia. Jeśli coś przepuszcza to też taki objaw jest możliwy (LPG wymaga bogatszej mieszanki, więc zalewanie może być nieodczuwalne przez kierowcę, a przy benzynie, jak już temperatury na dworze wyższe, będzie zalewał. Jak wygląda średnie spalanie LPG i Pb na chwilę obecną? Jeśli byłaby to kwestia tylko korekt, to spalanie gazu powinno być nominalne, jeśli masz dziurę w dolocie lub inną usterkę tego typu - prawdopodobnie będzie przepalał więcej niż powinien.
  • Helpful post
    #20
    mkpl
    Level 37  
    Rozwiązałem częściowo swój problem.

    LPG przełączało się szybciej niż uruchamiała się sonda lambda (praca w pętli zamkniętej), przez co totalnie rozjechała się mapa benzyny (16ms na start i zalewało silnik). Po załapaniu pętli zamkniętej czas wtrysku redukował się do około 3.8ms.

    Uruchomiłem silnik na lpg i poczekałem aż załapie lambda, przełączyłem na PB i silnik pracował równo. Odłączyłem sondę lambda i wróciło "szarpanie" po chwili się uspokoiło i czasy wtryskiwaczy się sukcesywnie redukowały aż do 4ms. Potem byłem się tak przejechać odcinek około 2km zostawiłem chwilę na wolnych obrotach i zgasiłem.

    Jak wystygnie całkowicie zobaczę czy to coś pomogło (liczę na to, że silnik zapamięta sobie ewentualne korekty).

    Byłem przed chwilą odpalić silnik i pali na dotyk choć ma jeszcze problemy z dodawaniem gazu. Widać metoda jakoś działa.
  • #21
    drzasiek
    CNC specialists
    Przepływomierza nie ma. EGR zaślepiony.
    Spalanie LPG w normie 8-9 L/100.
    Spalanie PB nie znane, dawno nie sprawdzałem.

    Jak uruchomić silnik na LPG? U mnie się chyba nie da bo mam albo automat albo PB.
    Lambda pracuje w zakresie 100-800mV, pomiar cały czas skacze.
    Wyświetla się na benzynie po chili, że pracuje w zamkniętej pętli.
  • Helpful post
    #22
    mkpl
    Level 37  
    To jedynie reset kalibracji ECU i powinno być ok.
  • #23
    drzasiek
    CNC specialists
    Tylko jak to zrobić?
    Odłączałem akumulator na całą noc, następnie uruchamiałem silnik do zadziałania wentylatorów i ciągle bez zmian.
  • #24
    mkpl
    Level 37  
    Jedynie kablem OpCom lub jechać na Tech'a. Zwykłe kabelki USB nie mają takich możliwości
  • #26
    drzasiek
    CNC specialists
    mkpl wrote:

    Uruchomiłem silnik na lpg i poczekałem aż załapie lambda, przełączyłem na PB i silnik pracował równo. .


    Możesz to rozwinąć?
    Co ten zabieg miał na celu i co to znaczy, że załapie sonda lambda? W sensie jak się przełączy sterownik na pętlę zamkniętą?
  • #27
    mkpl
    Level 37  
    Moja astra wystawiała w pętli otwartej czas wtrysku 17ms.
    Jak sonda lambda się zagrzeje przechodzi w pętlę zamkniętą i czas wtrysku spada do 4ms i silnik pracuje stabilnie. Odłączenie sondy znów zwiększyło czas wtrysku do 16ms ale nagrzany silnik jakoś łatwiej to "przepalał" i sterownik skorygował czas wytrysku "po obrotach".
    Obecnie też nie jest super bo czasy wtrysku są rzędu 8ms ale to już powinna załatwić samoadaptacja długoterminowa (trzeba pojeździć na benzynie).

    Mógłbym adaptacje wywalić kablem ale niestety nie mam teraz skąd pożyczyć bo znajomy pojechał na wakacje... a moim kablem z softem abcom się tego nie da zrobić.
  • #28
    helmud7543
    Level 43  
    Jeśli to kwestia zbyt wczesnego przełączania się na gaz (i jest szansa że z czasem złapie korekcje) to są dwie możliwości:
    1. Uruchamianie na benzynie i ręczne przełączenie na gaz po mocniejszym rozgrzaniu, niż gdy to robi z automatu.
    2. Jechać do gazownika i podnieść temperaturę przełączania (wtedy na automacie będzie przełączał później).
    Nie wiem czy to coś da, ale przynajmniej pierwszy sposób jest darmowy i bezpieczny.

    Jeśli masz STAG to uruchamiasz awaryjnie na LPG (ignoruje całkowicie benzynę) w ten sposób - trzymasz wciśnięty przycisk zmiany paliwa i jednocześnie włączasz zapłon. Wystartuje na gazie bez względu na temperaturę i nie przełączy na benzynę bez względu na błędy (np: koniec gazu w butli). Nie testowałem w praktyce, nie wiem co na to reduktor, jak będzie nie wyrabiał na zimnym to korekcje jeszcze bardziej się rozjadą...
  • #29
    drzasiek
    CNC specialists
    No ale u mnie w pętli zamkniętej pracuje nieprawidłowo. Czasy wtrysku ok 4 ms na wolnych obrotach.
  • #30
    helmud7543
    Level 43  
    Według mkpl to jest sposób, żeby złapał korekcję. Choć skoro jazda na benzynie nic nie dała to nie wiem. Nie wiem jak jest w tym silniku rozwiązane, natomiast u mnie w BMW są dwie korekcje - dla biegu jałowego i małych obciążeń oraz dla średnich i dużych obciążeń. Jeśli tutaj jest tak samo to jeszcze został jeden sposób. Dać mu kilka razy popracować na kilka minut na biegu jałowym.
    Jeśli powyższe metody nie pomogą to zostaje już naprawdę tylko ręczne skasowanie adaptacji.