Elektroda.pl
Elektroda.pl
X
TermopastyTermopasty
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Sterowanie żarówką triakiem

24 Mar 2020 23:21 228 12
  • Poziom 3  
    Witam,

    nieustannie napotykam problemy przy próbie załączenia żarówki 230 V AC. Co prawda ostatecznie w miejscu żarówki znajdzie się grzałka 2 kW, która załączana ma być, gdy temperatura spadnie poniżej zadanej wartości, jednak chciałbym, aby układ zadziałał wstępnie dla żarówki. Opór czujnika dla żądanej wartości temperatury wynosi około 4 kOhm, a w układzie tymczasowo zastąpiono go potencjometrem.

    Sterowanie żarówką triakiem

    Zastosowany triak to BTB24 - 600B.

    Po podłączeniu układu, żarówka świeci jedynie przez ułamek sekundy. Żarówka świeci nawet, gdy na wejście układu MOC3041 nie jest podane napięcie (po rozłączeniu obwodu 230 V), co wydaje mi się jest skutkiem zniszczenia MOC3041 po pierwszym podłączeniu.

    Pytanie: Dlaczego tak się dzieje, co należy w schemacie poprawić?

    Za wszelką chęć pomocy serdecznie dziękuję!

    Pozdrawiam Piotr
  • TermopastyTermopasty
  • Specjalista PLD
    Na początek zmniejsz 470 na 360 ohm, a między bramkę triaka i punkt N włącz opór 330 ohm. Powinno lepiej działać.
  • TermopastyTermopasty
  • Poziom 14  
    A masz triak przykręcony do radiatora, czy odpalasz "w powietrzu" ?
  • Specjalista PLD
    sosarek napisał:
    Nie prościej nabyć gotowy termostat? Koszt kilku złotych, u skośnych braci jeszcze taniej.

    Masz zapewne rację, jednakże nie jesteśmy handlowcami tylko elektronikami, a Człowiek pyta by się czegoś nauczyć a nie opędzić problem po linii najmniejszego oporu.
  • Poziom 3  
    Panie yego666, dziękuję za odpowiedź, spróbuję. Panie sosarek pewnie ma Pan rację, ale kieruje mną chęć nauki sterowania urządzeniami większej mocy ;)

    Panie warlocki radiator jest, ścieżki o grubości około 8 mm, odległość między ścieżkami około 6 mm, ale dziękuję za pytanie.
  • Poziom 14  
    Zapytałem, bo kiedyś spaliłem wiadro triaków, modyfikując schemat, a przyczyną był duży prąd i triak bez radiatora - puk i do piachu :)
  • Poziom 3  
    Po zmianie rezystora z 470 na 315 i dołożeniu rezystora 315 zgodnie (prawie) z zaleceniami, żarówka świeci, jednak świeci pomimo braku napięcia (zasilanie +5V jest rozłączone) na wejściu układu MOC3041, co prawdopodobnie świadczy o tym, że układ uległ uszkodzeniu, wcześniej działał poprawnie na niskim napięciu. Na szczęście mam jeszcze jeden taki układzik, tylko pytanie, dlaczego uszkodzeniu mógł ulec poprzedni, jeżeli podłączyłem układ zgodnie ze schematem?
  • Pomocny post
    Specjalista PLD
    Może się faktycznie moc uwalił. Dla pewności do sieci daję moc3063, bo przepięcia mogą przekraczać 400V.
    Pamiętaj że układ miałeś niewłaściwie połączony, a to mogło zabić moc'a.
    Zanim wstawisz nowy, przelóż żarówkę w gałąź N.
    Nie powinno to nic zmienić ale warto sprawdzić.
  • Pomocny post
    Poziom 37  
    Ze schematu z pierwszego postu może wynikać, że zamieniłeś miejscami anody triaka, zastosuj najlepiej typową aplikację któregokolwiek producenta.
    Z drugiej strony komparatorowi przydałaby się histereza.
  • Poziom 3  
    Rzeczywiście, wyjście MOC połączyłem z anodą A1 i bramką G, a nie z anodą A2 jak sugeruje poniższy schemat, na którym się o dziwo wzorowałem... Jak wrócę z pracy, to spróbuję połączyć tym razem poprawnie.

    Sterowanie żarówką triakiem

    Nasuwają mi się jeszcze dwa pytania:
    1. Dlaczego wcześniejsze połączenie uśmierciło MOC?
    2. Jak na pracę triaka wpływa detekcja przejścia przez 0 - MOC3041 ją posiada, ale np. 3021 już nie.
  • Poziom 3  
    Układ już działa, problemem było złe podłączenie triaka. Bardzo dziękuję za pomoc. Temat zamykam.
  • Poziom 3  
    Układ już działa, problemem było złe podłączenie triaka. Bardzo dziękuję za pomoc. Temat zamykam.

    Dodano po 1 [minuty]:

    Zamiana miejscami anod triaka.