Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

POWER-MOSFET - wzmacniacz do subwoofera

toopcool 09 Maj 2013 10:03 35517 29
  • Witam.

    POWER-MOSFET - wzmacniacz do subwoofera

    Od czasu do czasu buduje jakiś subwoofer i zawsze mam mały dylemat - czym napędzić głośnik ?
    Na początku mojej przygody z DIY wykonywałem wzmacniacze oparte o układy scalone ( TDA 7294 . LM 3886 , LM 4780 ).
    Najczęściej jednak nie sprawdzają się one w takiej roli.
    Często również impedancja 4 ohm powoduje że wzmacniacze scalone nie są w stanie poprawnie pracować z takim obciążeniem.
    Postanowiłem więc zbudować wzmacniacz na tranzystorach.
    Wykonałem kilka wersji opartych na popularnych tranzystorach IRF 540 / IRF 9540 .
    Pierwsze układy były bardzo proste a mimo tego różnica była kolosalna i wzmacniacze na układach scalonych poszły w odstawkę.
    Wzmacniacz zrobiłem z myślą o głośnikach 8 cali i 4ohm impedancji.

    POWER-MOSFET - wzmacniacz do subwoofera POWER-MOSFET - wzmacniacz do subwoofera

    Układ który prezentuję jest to zintegrowany wzmacniacz zawierający :
    - wzmacniacz mocy ze stabilizacją prądu spoczynkowego;
    - przedwzmacniacz z regulacją wzmocnienia i częstotliwości odcięcia;
    - układ automatyki włączania po detekcji sygnału audio na wejściu i wyłączenie po około 15 minutach przy braku sygnału audio;
    - układ zabezpieczeń DC na wyjściu , opóźnione załączanie głośnika i szybkie wyłączanie głośnika;
    - zintegrowany zasilacz do bloku mocy i przedwzmacniacza na jednym PCB

    POWER-MOSFET - wzmacniacz do subwoofera POWER-MOSFET - wzmacniacz do subwoofera

    PCB ma wymiar 162 mm x 100 mm.
    Na płytce znajdują sie praktycznie wszystkie elementy za wyjątkiem:
    - włącznika zasilania bezpiecznika ( będzie na panelu )
    - gniazda zasilania 230 V ( będzie na panelu )
    - wejęcia CINCH ( będzie na panelu )
    - termostatu ( będzie na radiatorze )
    - przełącznika fazy ( będzie na panelu )

    POWER-MOSFET - wzmacniacz do subwoofera

    Układ uruchamiałem stopniowo .
    Zasilam go transformatorem 180W i po wyprostowaniu na kondensatorach mam bez obciążenia +/- 39V .
    Jak na razie układ działa bez problemowo.
    Zaprojektowałem również panel ale na razie brak czasu na jego wykonanie.

    POWER-MOSFET - wzmacniacz do subwoofera


    https://www.youtube.com/watch?v=7Fu5KNIcSj0


    Fajne!
  • #2 09 Maj 2013 13:11
    ciarek15
    Poziom 16  

    Bardzo dobry pomysł z integracją wszystkich modułów na jednym PCB. Wygląda to bardzo estetycznie. A czy masz schematy i czy udostępnił byś je dla każdego modułu z osobna? Mnie zainteresował "układ automatyki włączania po detekcji sygnału audio na wejściu i wyłączenie po około 15 minutach przy braku sygnału audio" i chciałbym coś takiego wykorzystać u siebie we wzmacniaczu.

  • #4 09 Maj 2013 13:48
    ciarek15
    Poziom 16  

    Dzięki za schemat. A czy miałeś może gotowy wzór PCB? Czy projektowałeś odrazu tą zintegrowaną z resztą modułów wersję?

  • #5 09 Maj 2013 13:54
    toopcool
    Poziom 13  

    PCB które zaprezentowałem to któraś z kolei wersja .
    Wcześniej powstało kilka wersji zintegrowanych mniej lub bardziej , które dalej modyfikowałem do stanu jaki przedstawiłem.
    Nie mam projektu PCB do układu automatyki włączania .
    Mogę jedynie udostępnić plik EAGLE z schematem włącznika do edycji PCB.

  • #6 09 Maj 2013 15:11
    Arasssek
    Poziom 9  

    Witam a jak się sprawuje automatyczny włącznik nie ma z nim problemów ? tzn czy sam się nie załącza itd. jak możesz to wyślij mi pliki w eaglu na adres arek.materka(malpa)onet.pl z góry dziękuje.

  • #8 09 Maj 2013 15:53
    ciarek15
    Poziom 16  

    Arasssek napisał:
    Witam a jak się sprawuje automatyczny włącznik nie ma z nim problemów ? tzn czy sam się nie załącza itd.


    Znalazłem temat gdzie jest prezentowany ten układ na tym samym schemacie https://www.elektroda.pl/rtvforum/topic791200.html . Z tego co tam jest napisane to jest właśnie poprawiona wersja owego włącznika która wyeliminowała problemy z przypadkowym włączaniem i wyłączaniem się. Jest tam też wzór PCB jak i rozmieszczenie elementów.

  • #9 09 Maj 2013 16:07
    toopcool
    Poziom 13  

    Arasssek - Wyłącznik działa bezbłędnie , nie wariuje włącza się chwilkę po podaniu sygnału audio i wyłącza się po około 15 minutach .
    W załączniku schemat w EAGLE wersja 6.XX .

    Chrusta - czy lepiej czy nie lepiej ?
    Układ ma swoje przeznaczenie jak pisałem wcześniej ( 8 cali , 4 ohm ).
    W zasadzie opracowałem wersję dla impedancji 8 ohm i w niej zastosowałem jedną parę IRF240/IRF9240 . Całość zasilana wyższym napięciem .
    Powstała również wersja na 3 x IRF240 / 3 x IRF9240 ( jakieś 400W / 4 ohm) .
    Jednak są one jedynie w formie schematów i projektów.
    Układów jeszcze nie złożyłem i nie testowałem więc temat zamknięty.

    ciarek15 - jest to faktycznie schemat na którym bazowałem i w którym dokonałem małych modyfikacji .

  • #10 09 Maj 2013 16:20
    ciarek15
    Poziom 16  

    A można prosić jeszcze o schemat i jeśli jest możlwiość wzór PCB do "przedwzmacniacz z regulacją wzmocnienia i częstotliwości odcięcia" ? W jakim zakresie częstotliwości pracuje regulacja odcięcia? Czy w układzie jest wpleciony także filtr subsoniczny?

  • #12 09 Maj 2013 17:23
    ciarek15
    Poziom 16  

    Można byłoby jeszcze trochę przerobić układ, rozbudowywyjąc go o dodatkowy moduł ze wzmacniaczem operacyjnym. Nachylenie wzrosło by dwukrotnie. I tu proszę o zdanie ludzi którzy się lepiej w tym orientują niż ja, gdyż składam podobny przedwzmacniacz z regulacją i ciekaw jestem czy do takiego suba nachylenie lepiej ustawić na 12dB/okt czy lepiej 24dB/okt?

  • #13 09 Maj 2013 17:45
    raven1985_
    Poziom 8  

    Tak na marginesie chyba wypadało by podać, że wzmacniacz mocy to projekt Zbig-a.
    Obecnie można odnieść wrażenie, że jest nim autor wątku.
    A to nie prawda.

    Niestety nie mogę dodać linku.
    Temat o tym wzmacniaczu jest na diyaudio.pl

  • #14 09 Maj 2013 17:46
    toopcool
    Poziom 13  

    W zasadzie nie ma to znaczenia czy 12 dB czy 24 dB . Nie usłyszysz tego .
    Poza tym subwoofer podłącza się do wejścia niskopoziomowego w amplitunerze .
    Wyjście takie najczęściej ma już predefiniowaną częstotliwość odcięcia ustawianą w menu amplitunera .

    Nie jestem autorem poszczególnych elementów składowych całego wzmacniacza - nigdzie tak nie pisałem . Bazowałem na wyszukanych w sieci informacjach i schematach . Dokonałem modyfikacji w celu dopasowania do własnych potrzeb.

  • #15 09 Maj 2013 22:47
    Rafał 116
    Poziom 17  

    Z doswiadczenia wiem że lepiej rozłożyc poszczegolne moduły po subwooferze. Np zasilacz osobno cały układ pre i automatyka osobno i wzmak osobno. Po co? Zwykle diy robi sie z tego co sie ma. Czasem jest toroid a czasem ei. Rożną się sposobem mocowania i wymiarami a rozłożenie wszystkiego na moduły daje większe pole manewru.

  • #16 09 Maj 2013 23:00
    398216
    Usunięty  
  • #17 09 Maj 2013 23:07
    ciarek15
    Poziom 16  

    Rafał 116 napisał:
    Z doswiadczenia wiem że lepiej rozłożyc poszczegolne moduły po subwooferze. Np zasilacz osobno cały układ pre i automatyka osobno i wzmak osobno. Po co? Zwykle diy robi sie z tego co sie ma. Czasem jest toroid a czasem ei. Rożną się sposobem mocowania i wymiarami a rozłożenie wszystkiego na moduły daje większe pole manewru.


    I tutaj opinie są podzielone. Kiedy prezentowałem swój wzmacniacz było pare głosów w stylu że niepotrzebnie rozłożone jest na moduły. Powinienem zmieścić to w jedną całość, zaoszczędzając tym samym miejsc itd. itp. Więc ciężko jest trafić w gusta, bo tak źle i tak nie dobrze.

  • #18 10 Maj 2013 06:41
    toopcool
    Poziom 13  

    Rafał 116 - z doświadczenia wiem że jeśli wykonuje oddzielną komorę dla elektroniki to łatwiej w niej zamontować jedną PCB niż kilka i wykonać między nimi połączenia .
    Jeśli robisz jedną komorę wspólną dla głośnika i elektroniki to nie ma znaczenia czy masz kilka płytek czy też jedną i robisz montaż w obudowie jak Ci wygodnie.
    Ja jednak wtedy skłaniał bym się aby całą elektronikę umieścić na panelu z blachy i całość montować w tył obudowy .

    dj-MatyAS - nad mocowaniem płytki do panela i radiatora popracuję i raczej nie będzie z tym problemu ( mam dostęp do narzędziowni z fajnymi sprzętami i potrafię je programować ).
    Transformatorek to 1,5W i jest leciutki więc nie stanowi jakiegoś wielkiego obciążenia dla PCB 1,5 mm.
    Sensowne było by jeszcze rozdzielenie na dwa bloki . Jeden to zasilacze i zabezpieczenia natomiast drugi to przedwzmacniacz z końcówką mocy .
    Moim celem było jednak wykonanie jednego PCB .

    Wrzucam schemat , układ ścieżek i rozmieszczenie montowanych elementów .
    W rysunku montażowym wdarł się pewien błąd .
    Otóż część tranzystorów jest obrócona o 180 stopni.
    Są to :T1 BC548B; T2 BC548B; T3 BC546B; T4 BC546B; T11 BC548B; T12 2N5551; T14 BC548B; T15 BC548B; T16 2N5551; T16 2N5551.
    Należy je po prostu montować brzuszkiem w drugą stronę, odwrotnie niż w rysunku montażowym.
    Poniżej zdjęcie jak powinny być lutowane.
    POWER-MOSFET - wzmacniacz do subwoofera

  • #19 10 Maj 2013 09:53
    raven1985_
    Poziom 8  

    Kilka uwag jeszcze:
    - masa kiepsko poprowadzona (delikatnie mówiąc)
    - nie zostawia się do niczego nie podłączonych wysepek miedzi.
    - no i wypadało by zachować odpowiednie odległości między ścieżkami sieci a resztą układu.

  • #20 10 Maj 2013 10:05
    patrix20
    Poziom 10  

    raven1985_ napisał:
    Kilka uwag jeszcze:
    - masa kiepsko poprowadzona (delikatnie mówiąc)
    - nie zostawia się do niczego nie podłączonych wysepek miedzi.
    - no i wypadało by zachować odpowiednie odległości między ścieżkami sieci a resztą układu.


    Kolega może uzasadnić ten wpis, czy to tylko podbijanie statystyk postów ?

    - masa kiepsko prowadzona : Prosiłbym kolegę o podanie prawidłowego prowadzenia mas dla tego projektu
    - nie zostawia się do niczego nie podłączonych wysepek miedzi : a to dlaczego? to chyba nie jest wzmacniacz w.cz. ?
    - no i wypadało by zachować odpowiednie odległości między ścieżkami sieci a resztą układu: w/g mojej skromnej opini odległość jest wystarczająca.

  • #21 10 Maj 2013 10:29
    toopcool
    Poziom 13  

    raven1985 moderator z diyaudio ?
    - masa - aby coś zmienić należało by przebudować cały układ
    - nie zostawia się do niczego nie podłączonych wysepek miedzi - nie ma wpływu na funkcjonowanie układu , jeśli komyś przeszkadza może to zmienić
    - no i wypadało by zachować odpowiednie odległości między ścieżkami sieci a resztą układu - ścieżki sieci nie są w pobliżu ścieżek sygnałowych audio więc nie mają wpływu na generowanie bruuumu a i ta odległość jest wystarczająca do izolacji elektrycznej.

  • #22 10 Maj 2013 12:29
    raven1985_
    Poziom 8  

    patrix20 napisał:
    Prosiłbym kolegę o podanie prawidłowego prowadzenia mas dla tego projektu

    Chodzi mi głównie o prowadzenie ścieżki:
    - masy obciążenia
    - masy kondensatorów odsprzedających tranzystory mocy

    Masa obciążenia powinna być połączona osobną ścieżką do wspólnego punktu masy, po kondensatorach głównych zasilacza.

    Do ścieżki masy kondensatorów odsprzęgających nie powinno być podłączone nic innego, bo płyną przez nie mocno zniekształcone prądy obciążania.
    Spadek napięcia na tej ścieżce doda się do sygnału i zostanie wzmocniony.

    Efektem nie zastosowania się do tych zasad będą zniekształcenia.
    Stosowne pomiary są w książce i na stronie Duglasa Selfa.
    Jeśli Cię to nie przekonuje - polecam wykonanie ich samemu przy różnym połączaniu mas.

    patrix20 napisał:
    a to dlaczego? to chyba nie jest wzmacniacz w.cz. ?

    Nie zmienia to faktu, że to zła praktyka.
    W tym przypadku być może jest to bez znaczenia, ale nie zawsze tak będzie.
    No i miedź na płytce można lepiej wykorzystać :)

    patrix20 napisał:
    w/g mojej skromnej opini odległość jest wystarczająca.

    Proponuje zapoznać się z przepisami regulującymi tą kwestię, a przynajmniej użyć wyobraźni.
    Na płytce nie ma maski. Z czasem będzie na niej osiadał kurz. Chyba warto poświęcić kilka mm powierzchni płytki niż kusić los ?
    toopcool napisał:
    raven1985 moderator z diyaudio ?

    Tak.
    toopcool napisał:
    - masa - aby coś zmienić należało by przebudować cały układ

    Nic na to nie poradzę :)

    Nie czepiam się, aby się czepiać, czy dokopać autowi.
    Następnym razem zrobi lepszą płytkę :)

    PS
    Schemat i opis płytki jest bardzo nieczytelny.

  • #23 10 Maj 2013 16:47
    Bogdan 6
    Poziom 15  

    Ja jestem ciekaw czy przy tak małych punktach lutowniczych i ich wierceniu zostało jeszcze coś sztywnego do lutowania. Ja to wole je zawsze automatycznie powiększyć o 60 % jeszcze przed zaprojektowaniem płytki.

  • #24 12 Maj 2013 02:22
    laki_17
    Poziom 17  

    Mam pytanie co do programu w którym jest zaprezentowany schemat czyli Multisim. Jak on się sprawuje w przypadku układów analogowych? Czy nie zawiesza się itd podczas symulacji? Używałem go dawniej przez krótki czas w symulacji układów cyfrowych ale przy większych układach bardzo się wysypywał i konieczne było robienie układu od początku.

  • #25 18 Maj 2013 07:29
    toopcool
    Poziom 13  

    laki_17 - Multisim jeszcze mi się nie wysypał ani razu . Nie symuluje w nim dużych skomplikowanych układów , raczej symuluję pracę mniejszych bloków składowych .


    Bogdan 6 - w zależności od grubości wyprowadzeń stosuje różne wiertła wtedy punkty lutownicze nie są naruszone . Czasem również powiększam punkty lutownicze jednak w tym układzie zależało mi na małych wymiarach PCB.

  • #27 17 Mar 2014 19:55
    adamswid
    Poziom 13  

    Witam, próbuję uruchomić ten układ już kilka dni. Jest to mój pierwszy wzmacniacz na tranzystorach. Zacznę od tego że uruchamiam końcówkę z rezystorami szeregowo na obu wyprowadzeniach transformatora, radiator oczywiście przykręcony. Mosfety juz raz się spaliły. Teraz wyglądało to tak: przed wlutowaniem mosfetów napięcie na bramce wynosiło mniej niż 0.5V . i wzmacniacz prawie nie pobierał prądu. Po wlutowaniu na początku na rezystorach 47 ohm (te zabezpieczające miedzy transformatorem a pcb) było 1v ale prąd spoczynkowy nie dawał się regulować a na wyjściu głośnikowym było 6v napięcia stałego. Po chwili pomiarów rezystor (ten miedzy pcb a transfomatorem) zaczął dymić po wyłączeniu i ostudzeniu zmierzyłem jeszcze raz i na rezystorach było 27V a na bramkach mosfetów 6v i więcej zaś na wyjściu około 16v. Co może być nie tak i co powinienem sprawdzić? (Potencjometr też działa.)

  • #28 19 Mar 2014 08:05
    toopcool
    Poziom 13  

    Po co tam te rezystory wstawiłeś ?!
    Jeśli chcesz zabezpieczyć układ to szeregowo z uzwojeniem pierwotnym wstaw żarówkę .

  • #29 19 Mar 2014 22:04
    adamswid
    Poziom 13  

    Sprawdziłem mosfety i jeden ma przebicie. Myślę że rezystory nie miały wpływu na to. Następnym razem użyję żarówki. Jednak zanim w ogóle go podłączę muszę znaleźć przyczynę. Co powinienem sprawdzić w pierwszej kolejności? Tranzystory T5 T6 T7 są sprawne. A uszkodzeniu uległ Q3 albo Q2 nie wiem który dokładnie bo wylutowałem oba na raz i nie jestem pewien w końcu który jest który.

  • #30 21 Mar 2014 08:20
    toopcool
    Poziom 13  

    Zawsze gdy montuję jakiś układ sprawdzam elementy bo nawet w nowych zdarzają się uszkodzone . Rezystory powodują destabilizację układu ze względu na duży spadek napięcia przy ładowaniu kondensatorów .

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME